System Requirements

Glip Web App

If you're running Glip in a web browser, you'll need a recent version of Chrome, Firefox or Safari, or Internet Explorer version 9 or higher.

Glip Desktops Apps

Glip's desktop apps require either OSX 10.9 or higher, or Windows 7 or higher.

Glip Mobile Apps

Glip's mobile apps require either iOS 8.0 or higher, or Android 4.1 or higher.

Have more questions? Submit a request

Comments

Powered by Zendesk